Engine ping

Discussion in 'General Tacoma Discussion' started by rich, Sep 13, 2017.

  1. rich

    rich Member

    Hey group
    I've noticed on occasion that when accelerating I get a pinging or valve slapping sound
     
  2. Avatar

    Tacoma Forum Sign Up!

    Join TacomaForum.com Today - It's Totally Free!

    Are you a Toyota truck fan? If so we invite you to join TacomaForum.com. Our site is specifically designed for you and it's a great place for Toyota Tacoma Fans to meet online.
    Once you join you'll be able to post messages, upload pictures of your truck, and have a great time with other Toyota Tacoma fans. Whether your an old timer or just bought your Tacoma you'll find that TacomaForum.com is a great community to join. Best of all it's totally free!

    Join TacomaForum.com Today! JOIN FOR FREE

  3. whippersnapper02

    whippersnapper02 Negative Nancy

    There was a TSB about it but not sure if it applies now. I started using higher octane fuel to avoid it but then went 87 again and let it ride.
     
    Last edited: Sep 13, 2017
  4. OR17TRD

    OR17TRD Well-Known Member

    These are kind of ticky pinggy engines.
     
  5. whippersnapper02

    whippersnapper02 Negative Nancy

  6. 858_tacoma_guy

    858_tacoma_guy Well-Known Member

    I have this issue when I start up my truck. I have the 4.0l engine. Is it of any concern...? Or just a regular noise for our tacos
     
  7. OR17TRD

    OR17TRD Well-Known Member

    Normal as per the dealer... unless yours falls under the TSB.
     

Share This Page