Pass P/W problem (me and my big mouth)

Discussion in '2016 + Toyota Tacoma' started by texasred, May 18, 2020 at 1:06 PM.

  1. texasred

    texasred Well-Known Member

    2017 Tacoma Limited (So I like chrome and comfort. So shoot me.)

    Me and my big mouth. OR asked for recommendations on a portable jump starter. I recommended one that I've used for others' cars, but not the Taco. I shoulda known better. Of course my battery is dead when I FINALLY go to get my hair cut. Lots of clicking but no go. So I use my neato torpedo battery jumper (that I just recommended) and truck on down to O'AutoParts and got a new one.

    Suddenly, the front power windows are all wongo. Driver side wont "auto" down, passenger wont work from master switches but ok on door. Searched the old interweb and checked fuses and disconnected battery, let it sit, and reconnected. Now driver side window works fine, but passenger window still inop from driver door but works on passenger door. Window lock is not engaged and PDL works fine from either door as does all other windows. Every other electric/electronics appears to work fine.

    PLEASE tell me y'all have some more troubleshooting advise beyond replacing the BCM! (And remind me NOT to give any more recommendations)

    TIA
     
    Last edited: May 18, 2020 at 1:14 PM
    tooter, B-Man, B.C. and 1 other person like this.
  2. Avatar

    Tacoma Forum Sign Up!

    Join TacomaForum.com Today - It's Totally Free!

    Are you a Toyota truck fan? If so we invite you to join TacomaForum.com. Our site is specifically designed for you and it's a great place for Toyota Tacoma Fans to meet online.
    Once you join you'll be able to post messages, upload pictures of your truck, and have a great time with other Toyota Tacoma fans. Whether your an old timer or just bought your Tacoma you'll find that TacomaForum.com is a great community to join. Best of all it's totally free!

    Join TacomaForum.com Today! JOIN FOR FREE

  3. OR17TRD

    OR17TRD Well-Known Member

    That’s odd. Did you disconnect the entire batter (both terminals) or just disconnecting the negative battery terminal? 20 min.
     
    tooter, texasred and B-Man like this.
  4. Jersey Black Beauty

    Jersey Black Beauty Well-Known Member

    Exact same replace battery
     
    tooter likes this.
  5. Steverino

    Steverino New Member

    Nothing wrong with being a proud owner of the limited version!!
     
    tooter and texasred like this.
  6. OP
    texasred

    texasred Well-Known Member

    I just pulled them both and waited per suggestion...no go. :(
     
    OR17TRD and tooter like this.
  7. B.C.

    B.C. Well-Known Member

    Double check your ground.
    A bad ground will do the wildest and most unpredictable things to electrical.
    A couple of weeks ago I had a loader in the pit with a lot of weird things going on with it. Replaced all 4 batteries, the regulator, checked a pile of stuff. Nothing helped and problems would come and go with no pattern. I called finning and they sent out a mechanic who tried diagnosing the issues for 4 hours, he fixed nothing.
    I finally ran a second ground cable from the batteries to the engine block using a bolt that was actually a mount for the alternator bracket...problem solved.
    The original ground strap was something I looked at first, and I undid both ends and wire brushed it and the bolts.
    So I was fairly certain it had a good ground already.
    Electrical I usually check fuses first and ground second.
    Over the last 20 years I have seen some crazy issues in helicopters to, that were a bad ground.
    Last month with my own boat trailer it had really dim lights. I just aded a ground wire from trailer tongue to the hitch, and lights are super bright again.
    I truly hate electric problems.
    Especially on trailers!!!
     
  8. OR17TRD

    OR17TRD Well-Known Member

    Just disconnect the negative leave the positive attached. That will reset the ECU. 20 min.
     
    Scott Wyman, texasred, B-Man and 2 others like this.
  9. OP
    texasred

    texasred Well-Known Member

    Tried disconnecting negative terminal (twice) before posting.
    Ran a second ground to chassis. No good.

    Am I looking at $500 just to get the window working right?
     
    Last edited: May 22, 2020 at 2:59 AM
  10. OR17TRD

    OR17TRD Well-Known Member

    Maybe try taking the drivers door master switch out unplug and plug back in or make sure every thing is tight.
    Seems odd that multiple switches stopped working then all but one works now.
     
  11. Jersey Black Beauty

    Jersey Black Beauty Well-Known Member

    Start from the beginning
    Mistakenly,,did the cables get crossed when jumping ?
    Is the Nestor torpedo put out enough amp for the 17 ? A lot of electronics there.
    Did you get the same battery,the one the truck calls for?
    Really strange what happened
     
    texasred, tooter, B-Man and 2 others like this.
  12. Jersey Black Beauty

    Jersey Black Beauty Well-Known Member

    Sounds like you need to reset window module, the automatic feature probably lost the parameters in the module after Battery replacement
    Go to Google and type in How to reset power windows
    Hope this Works
     
    texasred, tooter, B-Man and 2 others like this.
  13. Jersey Black Beauty

    Jersey Black Beauty Well-Known Member

    Hey texasred. Has anything works for you
     
    tooter and B.C. like this.
  14. OP
    texasred

    texasred Well-Known Member

    Haven’t had a chance. I’ll let ya know.
    Appreciate the tip.
     
    tooter likes this.
  15. OP
    texasred

    texasred Well-Known Member

    No. Yes. Yes. Not from what I’ve read at TW.
     
    tooter likes this.

Share This Page